pfm

Photon file manager

Syntax:

pfm [-h height[%]] [-S i|m|n] [-s server]
    [-w width[%]] [-x position[%][r]] [-y position[%][r]]

Runs on:

Neutrino

Options:

-h height[%]
The height of the window, in pixels, or as a percentage of the screen height if % is specified.
-Si|m|n
The initial state of the main window (iconified, maximized, or normal).
-s server_name
The name of the Photon server:
If server_name is: This server is used:
node_path node_path/dev/photon
fullpath fullpath
relative_path /dev/relative_path
-w width[%]
The width of the window, in pixels, or as a percentage of the screen width if % is specified.
-x position[%][r]
The x coordinate of the upper-left corner of the window, in pixels, or as a percentage of screen width if % is specified. If r is specified, the coordinate is relative to the current console.
-y position[%][r]
The y coordinate of the upper-left corner of the window, in pixels, or as a percentage of screen height if % is specified. If r is specified, the coordinate is relative to the current console.

Description:

The pfm utility starts a graphical file manager that lets you browse directories and files, create and edit files, and so on.

The Photon file manager represents files and folders graphically. Double-click on a folder to open it and display its contents. Double-click on a file to open it in an associated application (if an association exists). The file manager also supports drag-and-drop operations -- for example, you can drag a file to a folder to move it there. You can right-click on a file or folder to view a shortcut menu, which contains a subset of the commands that are listed below.

You can quickly jump to an item in a long list by typing in the first few letters of the file or directory name.

Viewing and editing files

Task Menu command Shortcut
Create a new file File-->New-->File F3
Create a new folder File-->New-->Folder F4
Open a new file-manager window File-->New-->Window Ctrl-N
Open a selected folder File-->Open Enter
Open a selected folder in a new file-manager window File-->Open in Window Ctrl-Enter
View a selected file* File-->View
Edit a selected file* File-->Edit Ctrl-E
Open a selected file with a specific application File-->Open With Shift-Enter
Open a pterm window with the path set to the current directory File-->Open Terminal Ctrl-T
Refresh the file list File-->Refresh F5
Print the current file File-->Print Ctrl-P
Print the current directory listing File-->Directory
View or change a file's properties, including its size, owner, read/write/execute permissions, and access mode. File-->Inspect F9
Close the Photon file manager File-->Exit Alt-X

* You can view or edit only file types that are associated with an application. Use the Edit-->Associations command to add or change file-type associations.

Moving, deleting, and renaming files

Task Menu command Shortcut
Cut the selected file or folder and put it in the Photon clipboard Edit-->Cut Ctrl-X
Copy the selected file or folder to the Photon clipboard Edit-->Copy Ctrl-C
Paste a folder or file from the Photon clipboard into the current directory Edit-->Paste Ctrl-V
Delete the currently selected file or folder Edit-->Delete Delete
Rename the currently selected file or folder Edit-->Rename F2
Copy a file or folder to a defined bookmark location or a location that you specify Edit-->Copy To
Select all files and folders in the current directory Edit-->Select-->All Ctrl-A
Select all files or folders in the current directory that match a defined pattern Edit-->Select-->Pattern Ctrl-S
Unselect all selected files and folders Edit-->Unselect-->All Ctrl-U
Unselect all selected files and folders based on a defined pattern Edit-->Unselect-->Pattern
Invert the current selection--that is, selected files are unselected, and unselected files are selected Edit-->Invert Selection Ctrl-I
View or edit file-manager preferences, including whether to hide system files, font, and prompt behavior. See Setting pfm Preferences below. Edit-->Preferences F10
View or edit the associations between file types and applications. These definitions determine whether you can view or open a file from within file manager. Edit-->Associations F11

Navigating

Task Menu command Shortcut
View the last directory listing viewed Go-->Back Alt-<--
View the next directory listing viewed (only available after you've used the back command) Go-->Forward Alt--->
Move up one level in the directory tree Go-->Up One Level Backspace
View the home directory for the current user Go-->Home F6
Add the current directory to the bookmark list Bookmarks-->Add Current Directory Ctrl-D
Remove the current directory from the bookmark list Bookmarks-->Remove Current Directory Ctrl-R
View a bookmarked directory Bookmarks-->Directory

Setting pfm preferences

You can set pfm preferences by selecting Edit-->Preferences. Use the Preferences dialog to configure the following settings:

Setting Description
Filelist Options These settings allow you to show or hide system files that begin with a period ("dot" files), and list folders before files regardless of alphabetical order.
Filename Encoding These settings specify how pfm displays non-UTF8 encoded file names.
Filelist Font and Hotlist Font These settings specify the font, style, and size to use in the file list and the bookmarks (hotlist).
KeyFind Timeout This setting specifies the maximum time in milliseconds between keystrokes before the find by typing feature resets itself. Set to 0 to disable reset.
Copy/Move Overwrite and Delete These settings configure whether pfm prompts you before copying, moving, or deleting files.

Examples:

Run PFM using Photon server on node my_node:

pfm -s/net/my_node/dev/photon

Run PFM at initial position (10,10) with an initial dimension of 200*300:

pfm -x10 -y10 -h200 -w300

See also:

"Browsing files with the File Manager" in the Using the Photon microGUI chapter of the Neutrino User's Guide